Kirstein X-Drum DD-530 mit Apple Mac Mini und Garageband

  • Hallo Forum,


    ich bin absolut neu hier, aber hoffe, daß ich bei euch endlich den entscheidenden Hinweis bekomme. Ich habe mir das obige Drum-Set geholt und über USB an meinen Mac Mini angeschlossen. Der Mac erkennt auch das Drumset und in Garageband.
    Soooooo...... Nun möchte ich die Drumsets in GB über mein E-Drumset triggern. Leider bringe ich kein Ton heraus. Ich weiß, daß MIDI nur Steuerbefehle überträgt, aber anscheinend "versteht" GB das nicht.
    Ich hab auch schon mit Apple telefoniert, die konnten mir leider auch nicht wirklich weiter helfen. Eigentlich sollte es so funktionieren, meinten die......:-( Tuts aber leider nicht.... :-(


    Ich hab dann im I-Net auch noch was von Monitoring gelesen, finde aber in GB nix wo und wie man das einstellt. Apple hat mir auch einen Link geschickt, in der das beschrieben sein soll, aber leider kann ich das in meinem GB nicht umsetzen......:-( Hier der Link: GarageBand '11: Hören des echten Instruments oder der Mikrofoneingabe beim Abspielen und Aufnehmen (Monitor-Funktion )


    Ich hoffe, jemand hatte anfangs auch ein ähnliches Problem und kann mir weiter helfen. Danke schon mal dafür.


    Anbei ein paar Screenshots wie bei mir die Einstellungen sind und ihr dazu einen Eindruck bekommt.


    Ach ja.... Gesucht habe ich natürlich auch schon, aber nichts relevantes gefunden.... :huh:

  • Hi Liteville-301,


    bin kein GarageBand-Kenner, hab aber schon mal ein vergleichbares E-Drum an meinem Mac gehabt. Der Schritt, der mir anhand Deiner Screenshots zu fehlen scheint: Hast Du schon das "Audio-Midi-Setup" (unter Dienstprogramme) des Mac aufgerufen? Das ist in der aktuellen Fassung etwas tückisch, weil man (zumindest bei mir) erstmal nur die Einstellungen für Analog-Audio kommen (so wie in Deinem zweiten Screenshot zu sehen).


    Die wichtigen Midi-Einstellungen werden dann im Menü "Fenster" mit "MIDI-Studio einblenden" aufgerufen. Vielleicht kommst Du an der Stelle weiter …


    Viel Erfolg!
    Hajo K

  • Hi again,


    ich glaub, da gehen bei Dir gerade bein paar grundlegende Konzepte durcheinander, nämlich die von analogen und digitalen Aufnahmen. Ich bin mir ziemlich sicher, dass die Monitor-Funktion für Dich keine Rolle spielt:

    Hier der Link: GarageBand '11: Hören des echten Instruments oder der Mikrofoneingabe beim Abspielen und Aufnehmen (Monitor-Funktion )

    Echte Instrumente/Mikros = analoge Aufnahme = Monitor-Fuktion nötig. Das wäre bei Dir der Fall, wenn Du die Signale Deines E-Drums vom Audio-Ausgang zum Mac führen würdest. Du würdest also aufnehmen, was Dein Modul gerade klanglich liefert. Hier kommt auch die Monitor-Funktion zum Tragen: Wenn Du z. B. eine Gesangsspur aufnehmen wolltest, müsstest Du ja die bisher aufgenommene Musik von GB hören - dafür gibt's den Monitor.


    Was Du vermutlich vorhast, ist die Aufnahme eines "Software-Instruments" in GB, das findest Du hier beschrieben:
    https://www.youtube.com/watch?v=N2AlGpF4jEI


    Viel Erfolg,
    Hajo K

  • YIIIIIIIIIIEEEEEEEEEEPPIIIIIIIIEEEEEEEE!!!!!!!!


    Es funktioniert!!!!


    Was wars? Offensichtlich ist das USB Kabel zu lang oder einfach nur Schrott!! Offensichtlich geht dazu wenig Power drüber.
    http://www.amazon.de/gp/produc…oh_aui_detailpage_o05_s00



    Jetzt hab ichs an nen USB Hub angeschlossen und nun gehts. Werd aber evtl. mal noch ein anderes ausprobieren. Denn manchmal hats trotz Hub auch Aussetzer.....
    Sieht zwar gut aus, ist aber anscheinend doch Schund...


    Boooaaahhh ey!! Was für´n Sound meine E-Schießbude nun schmeißt!!!


    Danke Hajo und schöne Grüße ins Forum!!!! :thumbsup: :thumbsup: :thumbsup:

  • Ein kleines Problem hab ich aber noch. Von Zeit zu Zeit reißt die Datenverbindung ab. Und dann muss ich erst wieder das Kit ausschalten und wieder einschalten, dann gehts wieder....
    Ich habe nun ein 1,8m statt ein 3m USB Kabel dran, aber selbst da passiert´s manchmal...... ;(


    An was kann das liegen?? ?( ?( Hab auch schon nen USB-Hub dazwischen, aber selbst da kommts ab und zu vor. Ein wenig ärgerlich das Ganze.... :huh:


    Sind die 1,8m immer noch zu lang?? Bringt so´n Aktivkabel was?? ?(
    http://www.thomann.de/de/thomann_usbrepeater.htm



    Das 1,8m Kabel ist ein Markenkabel von Belkin....




    Danke schon Mal!!!!! :thumbsup:

  • Also 1,8 Meter sind definitiv nicht zu lang. Aber es kann trotzdem am Kabel liegen!
    Was für USB-Kram ist denn sonst noch am MiniMac aktiv?
    Ich würde auch mal einen anderen USB-Port versuchen...


    Sind die Mac-USB-Treiber (und sonstige Mac-Software, die damit zu tun haben könnte) aktuell?



    Das Kirstein-Ding ist doch usb-mäßig garantiert "class-compliant" und hat keinen speziellen Treiber, oder?


    Schon mal ein Midi-Interface mit dediziertem Treiber installiert und das Modul über Midi (5-Pol) angeschlossen? (z.B. das Roland UM-One MkII) - spätestens dann sollte es fehlerfrei gehen; wenn nicht, ist irgendwas mit dem USB vom Mac faul, oder dieses Garageband (aktuell? - Midi-Problem bekannt?) kommt nicht klar... ;)

  • Also,...... Ich hab nun noch nen USB 3.0 Hub von IAnker dran.


    http://www.amazon.de/gp/produc…oh_aui_detailpage_o00_s00



    Außerdem vom Drum zum Hub ein USB 2.0 Kabel von Belkin, eben das mit 1,8m.


    https://www.conrad.de/de/ansch…-zertifiziert-993899.html


    Das Drum hat nur USB 2.0!!


    Vom Hub geht das mitgelieferte Kabel zum Mac. und das ist gerade am linken Anschluss, von hinten gesehen, eingesteckt. Sollte aber doch egal sein, oder?? ?(


    Ich hab auch mal gelesen, dass die Funkmäuse auch Probleme machen. die hab ich nun mal auch direkt am Hub angesteckt. Logitech M705 Funkmaus.


    Aufm Mac ist El Capitan!! Sollte also alles aktuell sein..... :thumbsup: ?(



    Für das Drum-Set brauchts keinen Treiber. Plug and Play.....


    Momentan läufts grad recht ordentlich. Schau ma mal wie lang...


    Hoffentlich bleibts so... Falls nicht, meld ich mich nochmal....




    Danke schon Mal und nun muss ich üben, bin ja schließlich das absolute Greenhorn....... :D ^^ :thumbsup: :thumbsup:


    Gruß
    Claus

  • Hallo zusammen,
    bin neu hier und habe ein ähnliches Problem. Habe meiner Tochter auch das xdrum 530 geschenkt, sie spielt inzwischen nicht mehr so oft, mich hat es aber gepackt. Sounds sind nicht der Hit, da habe ich das Teil einfach mal an das iPad mit einem cameraKit und einem usb–Kabel angeschlossen. Angeschaltet, Garageband gestartet, im großen und ganzen läuft das ganze für meine Ansprüche echt gut. Sounds sind deutlich besser, nur reagiert das Crash oft gar nicht und bei manchen Kits reagiert das Standtom gar nicht. Kann das auch am usb-Kabel liegen?

    Einmal editiert, zuletzt von Lucinio ()

  • nur reagiert das Crash oft gar nicht


    Das hört sich seltsam an, wenn die Midi-Noten-Zuordnung stimmt. Dann ist vielleicht das Becken-Pad kaputt!? (kommt bei Medeli Cym-Pads durchaus häufig vor). Die Midi-Noten-Zuordnung sollte stimmig sein, und sie ist für ein GarageBand-Drumkit auch nur im Modul einstellbar, da GB da meines Wissens nach nichts bietet (in Sachen Transponieren von einzelnen Kit-Piece-Midinoten oder Midi-Learn). Generell ist GB aber nicht wirklich e-drum geeignet, schon aus Latenzgründen: auch wenn du vermeindlich keine Latenz merkst, ist sie dennoch im Gegensatz zu Host-Programmen mit Core-Audio-Zugriff viel zuviel vorhanden. ;) Und am USB-Kabel liegt dein Problem, wie du es schilderst, nicht.

  • Die MIDI–Zuordnung passt. Das Standtom funktioniert auch bei ein paar Kits aus GB, nur eben nicht bei allen. Das Becken ist auch nicht kaputt. Zumindest funktioniert es einwandfrei, wenn ich das Drum nicht an das IPad angeschlossen habe. Seltsam trifft es ganz gut ;) und ich will auch nichts aufnehmen, mischen einspielen usw. sondern nur ein paar gescheite Sounds möglichst unkompliziert spielen können, ohne mir nochmal ne teure Software zu kaufen.Und dann sollte das ganze mit dem Pad möglich sein, GB habe ich eh...

    Einmal editiert, zuletzt von Lucinio ()

  • ...möglichst unkompliziert spielen können, ohne mir nochmal ne teure Software zu kaufen.Und dann sollte das ganze mit dem Pad möglich sein, GB habe ich eh...


    "Möglichst unkompliziert" (vielleicht auch komfortabel bei wenig Kompliziertheit) geht in Sachen Software-Drumming aber (auch wie du zumindest teilweise bereits siehst) echt anders. ;)

  • Die Midi-Zuordnung kann von Kit zu Kit unterschiedlich sein bei GB, da GB kein GM oder XG Layout verwendet (aber sich zum größten Teil ähnlich verhält bei der Zuordnung).
    Beispiel: Bei Kit 1 liegt das Floortom auf der Midinote F1, bei Kit2 aber auf F#1 oder G1, Das Modul sendet aber F1: ergo: Kein Sound (falls F1 nicht belegt ist). Das kannst Du z.B. mit einem Midikeyboard herausfinden, ob dem so ist oder einfach Step by Step die Midinoten im Modul für das Floortom ändern und danach drauf hauen.

    "The first rule of drumming: If you make a mistake, turn around and look angrily at the bass player" - Nick Mason

  • Vieeelen Dank! :thumbsup: Funktioniert mit den Midinoten. Es gibt unterschiedliche Midinoten, die den selben Klang erzeugen (zumindest hört es sich für mich so an), aber eben immer nur eine, die bei allen Kits funktioniert. Verstehen muss ich das glaub nicht, geht ja jetzt aber.


    Nur die Becken sind noch nicht ganz so wie sie sein sollten. Habe das ausgiebig getestet, liegt ganz einfach daran, das die dualzone nicht sauber funktioniert (auf dem Modul nennt xdrum das auch rimshot, der aber nur bei Lust und Laune reagiert) und dann auch bei den unterschiedliche Zonen teilweise die Midinoten auch bei verschiedenen Kits in GB nicht identisch sind.


    Stellt sich jetzt nur noch die Frage, ob die Becken einfach entsprechend des Preises des drums nur schlecht sind oder eben defekt.


    Nick74: Auch Dir vielen Dank! Scheint aber doch jetzt einigermaßen unkompliziert zu funktionieren! ;)

Jetzt mitmachen!

Du hast noch kein Benutzerkonto auf unserer Seite? Registriere dich kostenlos und nimm an unserer Community teil!